Other Post discussion on all other models not listed above here.

190e transmission pains

  #1  
Old 02-16-2009, 06:38 PM
Junior Member
Thread Starter
Join Date: Feb 2009
Posts: 1
Default 190e transmission pains

About 3 months the plastic governor gear snapped due to a spring becoming jammed in the gears of the secondary pump on my '91 190e (722.4 tranny). It was a pain to fix this but i fixed it and all seemed right again. However, yesterday while comming home from work, the car drove just fine for the first 15 mins or so. Then I stopped on a red light and when the light turned green I stepped on the gas, the revs went up to ~3000 rpm but the car just creeped at about a slow walking speed. The reverse gear works great but no forward to speak of. When the revs went to ~6000 rpms the car jumped and seemed to drive fine, till the next red light, two blocks down, then the same thing, no forward. I checked the control cable from the thrattle to the tranny, seemed fine. Between the gov. and now this I'm somewhat scared that I need a new tranny. Does anyone have any tips as to what the problem can be? Please help
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
harryi
New Mercedes Benz Forum Members Area
0
05-02-2010 02:36 AM
galla900
General Tech
0
02-12-2008 10:10 PM
honkytonkhank
General Tech
0
12-05-2006 02:19 AM
kustom_soundz
General Tech
0
07-14-2006 11:24 AM
jimmyfly
General Tech
1
03-15-2006 09:44 PM


Thread Tools
Search this Thread
Quick Reply: 190e transmission pains


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.