Diesel Discussions Only diesel topics should be posted here.

Diesel Injection Pump Issue?

  #1  
Old 10-21-2015, 11:29 PM
Junior Member
Thread Starter
Join Date: Oct 2015
Posts: 2
Default Diesel Injection Pump Issue?

Hi all,
Got my hands on an 82 Mercedes 300D Turbo, 156k miles, automatic, Golden Fuel Systems WVO kit installed.

Starts up fairly easy. Smokes a lot on start up and acceleration. Idles rough but does not stall out. Lack of power, but the engine runs smoother above idle and at higher rpm's.

I went to bleed air from fuel lines. Did so successfully. But I found one fuel line does not have any fuel coming out from the pump. I searched the forums but couldn't find anything specific except that it may be a stuck element?

Any ideas on how I go about diagnosing this? I did remove that affected hard line and blow it out with compressed air. It is not clogged.
 
  #2  
Old 10-22-2015, 12:17 AM
Junior Member
Thread Starter
Join Date: Oct 2015
Posts: 2
Default

Yikes that bad huh. I'll just take it one step at a time then. I think this car is interesting. I'm willing to put some time into it.
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
timwstephens
Diesel Discussions
1
01-27-2009 12:17 PM
treadstone71
Diesel Discussions
9
03-29-2008 01:21 PM
Fausto
Diesel Discussions
0
09-26-2007 06:20 PM
scottflys2
Private 'Wanted' Classifieds
0
06-01-2007 10:38 AM
Bigeasyherb
Diesel Discussions
1
01-28-2005 12:57 AM


Thread Tools
Search this Thread
Quick Reply: Diesel Injection Pump Issue?


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.