Go Back  Mercedes Forum - Mercedes Benz Enthusiast Forums > Mercedes Benz Models > Diesel Discussions
Reload this Page >

Oil pressure gauge, signals lights, wipers and speedotomer not working.

Diesel Discussions Only diesel topics should be posted here.

Oil pressure gauge, signals lights, wipers and speedotomer not working.

  #1  
Old 11-02-2015, 03:14 PM
Junior Member
Thread Starter
Join Date: Oct 2015
Posts: 1
Default Oil pressure gauge, signals lights, wipers and speedotomer not working.

I have a newly acquired 83 240D 4 speed manual transmission that runs really good after changing fuel filter. However, several items are not working on the instrument panel. They are the oil pressure gage, speedodotomer, signal lights and wipers. I checked all fuses and they all appear to be good. Is there a relay somewhere that controls these items?






83 240D 4 speed 367,000 miles Yellow
78 300D Automatic 154,678 miles Red
2002 ML 320 138,000 miles
95 BMW 525I 209,124 miles
2005 BMW 745I 80,000 miles
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
patricknif
Mercedes S Class
0
03-04-2012 06:38 AM
MERCEDESTIFFANY
New Mercedes Benz Forum Members Area
3
11-05-2011 04:24 PM
190dfreak1986
General Tech
0
09-10-2010 10:23 PM
ddtbreakfast
Mercedes E Class
2
04-21-2008 11:34 PM
slick1
Mercedes C Class
0
07-30-2007 07:05 PM


Thread Tools
Search this Thread
Quick Reply: Oil pressure gauge, signals lights, wipers and speedotomer not working.


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.