Other Post discussion on all other models not listed above here.

1991 300E Hesitates/sputters NO POWER

  #1  
Old 05-31-2014, 07:00 PM
Junior Member
Thread Starter
Join Date: May 2014
Posts: 1
Default 1991 300E Hesitates/sputters NO POWER

I have a 1991 300E with 147K. I purchased the vehicle "non-running" brought it home and charged the battery and was able to start it. It ran horribly while misfiring. It was spitting and sputtering and also popping. I put a bottle of seafoam in it with some fresh gas thinking that would clear it up and it didn't. The car wouldn't even idle until it was warmed up and you had to baby it to get it warmed up or it would stall. I took it to a mechanic, for which it sat for 2 months after him spending only an hour and a half on it. He got it to idle, which he said he had made an adjustment on the air/fuel mixture. Needless to say I went and got it and now im stuck on what it might be. It now will start up and idle fine. Even sitting in park you can rev it up and you can here a light miss but not near like it was. When you put it in gear and attempt to drive it, there's just not enough power. It sputters and just putts along. Here's what I do know. Upon inspection the cap and rotor look to be in very good condition. The spark plugs are new (bosch) I replaced those when I got the car. I still feel its a fuel related problem but cant pin point it. The OVP fuse is good so I think we can rule that out. Also when it was hard to start it would start with starting fluid or by putting a little fuel in the intake. It has sat for atleast 6 months since being broke down and the fuel smells fresh as I did put some in when I got it. When it warms up there is an odd odor but Im thinking its probably the seafoam. I would love to get this thing back on the road but don't know what to do at this point. Thanks in advance!
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
morav
Diesel Discussions
4
09-04-2011 10:15 AM
MBBalla
Mercedes E Class
1
12-20-2006 11:04 PM
stryj
Mercedes E Class
3
02-06-2006 11:35 AM
pipo8
Mercedes E Class
3
08-13-2004 02:59 PM
driller
General Tech
1
03-02-2004 06:14 PM


Thread Tools
Search this Thread
Quick Reply: 1991 300E Hesitates/sputters NO POWER


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.