Mercedes SLK Class All Mercedes SLK Roadsters.

High beam lights don't work

  #1  
Old 10-25-2009, 08:33 PM
Junior Member
Thread Starter
Join Date: Oct 2009
Posts: 1
Default High beam lights don't work

I have a 1999 Mercedes SLK 230 and the high beam lights don't work. I have checked the high beam lights and they are OK. I can add current to the breaker and they work, but there is no power to the breaker. I assume that the problem is in either the combination switch on the steering column, or wiring between the switch and the breaker. Low beams are OK. Any ideas on how to determine the exact problem?
 
  #2  
Old 02-22-2010, 04:39 PM
Junior Member
Join Date: Oct 2009
Location: durango co
Posts: 2
Default

if your fuses are ok you'll have to test your wiring the best to do that is to just get into the combination switch be careful with the airbag and get a wiring diagram and test for output at the switch i'ld almost bet its in the switch the high beam prong on the switch has tendacy to get lose
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Kaiser Sozé
General Tech
3
09-22-2010 06:04 AM
e55 ///amg
Mercedes E Class
3
02-20-2010 02:45 AM
mortgagespecialist79
General Tech
1
11-05-2008 05:25 PM
Bootcamp
Mercedes A Class
0
02-25-2007 09:50 AM
fly_major_fly
Off Topic
4
12-10-2005 03:12 AM


Thread Tools
Search this Thread
Quick Reply: High beam lights don't work


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.