Mercedes M Class Mercedes ML350 and Mercedes ML500 SUV's.

2001 ML320 Key Remote stopped working...best solution?

  #11  
Old 02-27-2015, 11:16 PM
Junior Member
Join Date: Feb 2015
Posts: 1
Default

worked a treat - thanks for the advice
 
  #12  
Old 11-17-2015, 01:53 PM
Junior Member
Join Date: Nov 2015
Posts: 1
Default

Originally Posted by mbenz80 View Post
Hi Todesto,
you are not finalizing your programing. That is why they are working but only ones. Your keys are OK.
With all doors closed:
1. turn key to pos. 2 then back to pos. 0 and remove it.
2. within 10 sec. press and hold lock button.
3. Now push unlock 5 times while still pressing down lock button.
4. Release lock button.
You came all the way to this point but there is one more step to re-synchronization.
5. PRESS TAIL GATE BUTTON TO COMPLETE SYNCHRONIZATION.
This last step is not mentioned at all in my original 1999 ML320 owner's manual.
But it workes, I got two remotes working for my Ml thisway.
Bernard
Hey ~

I wanted to reach out and thank you for this. It happened to me last week on my 2013 C300 and read this and was able to correct it today.

Thanks again for the details.
 
  #13  
Old 05-29-2017, 02:54 AM
Junior Member
Join Date: May 2017
Posts: 1
Default I have the same issue

Guys
i just bought a 2001 ML430
it has only 1 key and dealers tell me they no longer have the keys to order so if I don't fix this I'm screwed.
i followed the steps and my key after the one time locking or unlocking does not save the code and the buttons don't work. I can only manually operate my car. It sucks.
please let me know if there is anything else I can do to get it working. I really approve it.
Thank you.
 
  #14  
Old 08-25-2017, 12:36 AM
Junior Member
Join Date: Aug 2017
Posts: 1
Default

My car shutters when I step on the gas.... I had fuel pump replaced same problem ml320 2002
 
  #15  
Old 08-25-2017, 01:15 PM
Join Date: May 2012
Posts: 2,070
Default

Originally Posted by Talaunda Bolden View Post
My car shutters when I step on the gas.... I had fuel pump replaced same problem ml320 2002
Hello - are you able to pull the codes? I would also look at your injectors.
 
  #16  
Old 11-08-2017, 03:45 PM
Junior Member
Join Date: Nov 2017
Posts: 1
Default Great advice!!!

I tried the resetting of the key to unlock and it worked great, I really appreciate the advice!!
I have another issue, I had my ML 320 painted and they removed the rear doors handles without removing the back inside panels, now they don't open the doors from the outside.
Any suggestions?
 
  #17  
Old 12-14-2017, 09:31 PM
Junior Member
Join Date: Dec 2017
Posts: 1
Default 2001 ML 430 keys still not working

Hi Guy's, I tried this procedure with the final step of pressing the tailgate button and nothing worked, so I locked the car, and did all the steps again, this time when I pressed the tailgate button, it unlocked!

So I went outside to test the key buttons, and nothing worked any additional thoughts or advice?

Thanks

Mark
 
  #18  
Old 02-02-2018, 08:53 PM
Junior Member
Join Date: Feb 2018
Posts: 1
Default

My mechanic says the 2000 ML 320 has a limited number of activations and once you hit the limit you have to replace the remote. I contacted the dealer and they said that there are no longer available and said that I would no longer be able to use a remote. Is this true, what can I do. I have one that works is the one that was least used. Any help would be appreciated. Programming was attempted but nothing. Is there any way to see if the remote is transmitting or am I just out of luck?

Thanks
 
  #19  
Old 11-21-2018, 06:18 AM
Junior Member
Join Date: Nov 2018
Posts: 1
Default

hi all, thanks for your help in advance.

I am wondering if anyone had been able to resolve this. based on the above posts, the reprogramming works for some.
but for the others not having luck with this, did anyone find any other fix/solution to this? (Thanks)

the resync procedure (hold lock button+press unlock 5times+press any other key) works for me once within 10 seconds of taking it out of the ignition, then it doesn't after.
also my keys did not go bad at the some time, there is about 2-3 months in between.

before this happened, I had changed the battery and everything was fine for a few weeks/months. remote lock/unlock was working with no issues at all.

One day I went for lunch, came back and the remote central unlock stopped working. I used the spare key for a few months until it also went bad. (due to this I am hesitant to accept this is an aam issue - as keys did not go bad at the same time)
tried almost all things I have seen on the internet with no luck.

fyi. central locking button in the console works. just the remote central lock/unlock does not work. car start and runs just fine. (just with an annoying procedure of locking the car from console and then lock by key)

location: australia, 2001 ML320.

hoping someone out there has figured out the solution. any help appreciated!! thanks.
 

Last edited by trendy08; 11-21-2018 at 06:20 AM.
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Daniel L.
General Tech
0
11-26-2012 12:05 AM
rorymcmillan88
Mercedes C Class
1
04-07-2012 12:05 PM
patricknif
Mercedes S Class
0
03-04-2012 06:38 AM
vmb2000_uk
Mercedes S Class
0
03-08-2011 02:11 PM
JOIFUL
Mercedes M Class
2
04-21-2008 09:09 PM


Thread Tools
Search this Thread
Quick Reply: 2001 ML320 Key Remote stopped working...best solution?


Advertising
Featured Sponsors
Vendor Directory

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.