General Tech Post general Mercedes Tech questions here.

Windscreen Wiper Speed Problem

  #1  
Old 03-05-2007, 08:03 PM
Thread Starter
Join Date: Mar 2007
Location:
Posts: 8
Default Windscreen Wiper Speed Problem

Hi everyone

I have a 190 2.0 1989. The windscreen wiper speed for both positions II and III seem to run the wipers at the same speed. Is this more likely to be a problem with the indicator arm or could a relay be at fault?

Any help would be greatly appreciated

Colin

 
  #2  
Old 03-05-2007, 11:36 PM
chassis221's Avatar
Senior Member
Join Date: Feb 2007
Location: Philadelphia, Pa
Posts: 2,691
Default RE: Windscreen Wiper Speed Problem

You can try lubing the wiper arm with anti seize, there is a cap that can come off of the arm towards the bottom of the arm. 5 inches long 1.5- 2 wide. it pops off.there is a piston that moves in and out this gets dry and will eventually stop moving all together. this might help your condition. common problem.
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Candy68
General Tech
1
07-17-2011 07:38 PM
col190
General Tech
0
03-21-2008 05:57 AM
mat24
New Mercedes Benz Forum Members Area
0
12-19-2007 07:47 AM
horseybird
Mercedes CLK Class
1
10-27-2007 02:12 PM
gina2201
Mercedes C Class
6
11-30-2005 10:03 PM


Thread Tools
Search this Thread
Quick Reply: Windscreen Wiper Speed Problem


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.