Diesel Discussions Only diesel topics should be posted here.

E320 2006 Bluetek changed Turbo now slow acceleration

  #1  
Old 10-03-2016, 07:32 PM
Junior Member
Thread Starter
Join Date: Oct 2016
Posts: 5
Default E320 2006 Bluetek changed Turbo now slow acceleration

I just changed the turbo, (turbo shaft broke in half, about 3 months ago, changed EGR and Oil cooler, turbo shop said oil degrading made turbo go bad, said probably before oil cooler was changed) removed and cleaned the Intercooler and drove the car until all oil burned out of exhaust. For about 12 miles, the car really smoked (white smoke from exhaust) and after that car seemed to run OK, Check Engine light stayed on during that time. Diesel mech told me to erase the codes and see if they came back on. Did that. Check engine and Codes stayed off. Then drove about 60 miles. Car did good. BUT after about 75 miles coming back on final stretch, car seemed to bog down in acceleration. Car slowly got back to 65 but couldn't get any pep out of car. No check engine light or codes displayed. Rechecked all connectors and things under hook. everything looks good. Oil and water levels are fine. Any Ideals on what's wrong??
Thanks.
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
jeffb
General Tech
6
01-02-2009 08:33 PM
cade111
General Tech
3
02-20-2007 07:53 PM
dxprince
Mercedes E Class
2
02-03-2007 07:32 AM
NoFear10199
Mercedes M Class
3
11-15-2004 05:11 PM


Thread Tools
Search this Thread
Quick Reply: E320 2006 Bluetek changed Turbo now slow acceleration


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.