Diesel Discussions Only diesel topics should be posted here.

1985 300TD Power Loss

  #1  
Old 05-31-2016, 09:10 PM
Junior Member
Thread Starter
Join Date: May 2016
Posts: 2
Default 1985 300TD Power Loss

Hi, for about a couple months now, I've been feeling a slight tug on my car whenever I am driving up a hill or pulling out from a stop sign. It gets worse as time goes on and when I have the AC, sometimes it seems as if the engine is about to quit. There's has also been a small clicking noise coming from the engine when in idle or low speed. My first thought was to replace both fuel filters and checked the fuel tank screen, which I did, and it was clean. I have also replaced the air filter and checked all visible* vacuum lines and there were no leaks.

Has anyone had the same problem? If so, what did you do to fix it? The car is in great condition and has over 260k miles on it.

* I say visible in this sense cause I know majority of the car runs on vacuum and the whole system can be a real pain. I might have missed one connection that is under something deep under the hood but I've done a through look and didn't find any.
 
  #2  
Old 05-31-2016, 10:09 PM
Junior Member
Thread Starter
Join Date: May 2016
Posts: 2
Default

Thanks! I have not done that and I've driven the car for around 30k miles. I will do that!
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
jsd3024
Mercedes SL Class
3
11-24-2013 07:24 PM
lhb consulting
Mercedes SLK Class
1
07-24-2005 06:08 PM
larryms
General Tech
8
02-03-2005 12:01 PM
kzr1310
General Tech
3
07-04-2004 09:58 AM
papadude
Mercedes E Class
2
03-14-2004 06:38 PM


Thread Tools
Search this Thread
Quick Reply: 1985 300TD Power Loss


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.