Diesel Discussions Only diesel topics should be posted here.

1985 300sd NO POWER will not rev Bad lift pump? need help!

  #1  
Old 05-11-2014, 01:56 PM
Junior Member
Thread Starter
Join Date: May 2014
Location: Cumberland Gap Tn
Posts: 18
Default 1985 300sd NO POWER will not rev Bad lift pump? need help!

Hey guys this is my first post on the forum but have browsed around on here before. So I'll try to explain this the best I can,I traded for my second 300sd a couple of days ago and I'm having a hard time figuring out what's going on. The car has NO power barely even idles just bucks and shakes and will eventually die has a small amount of greyish white smoke coming out of the tail pipe when idling. The car barely even made it in my garage I have to almost hold it on the floor to get it to just idle..
So I started troubleshooting and checking the things I usually check first,changed the filters,Cleaned Alda banjo,tank screen,adjusted the Alda screw,checked the turbo shaft play,blew the fuel lines out going to the tank,all the obvious things. I came across something that I believe is the problem but wanted to talk to you guys before completely ruling everything out. The primary clear filter has VERY little fuel in it then drains itself and dies. Appears as if the fuel lift pump is bad and the engine is starving for fuel. Tried pumping the primer handle and nothing it's like it's not pumping anything. What do you all think is going on? Should I replace/rebuilt the lift pump? Any help is greatly appreciated I'm at a standstill now with it.
 
  #2  
Old 05-11-2014, 04:22 PM
Junior Member
Thread Starter
Join Date: May 2014
Location: Cumberland Gap Tn
Posts: 18
Default

Oh ok. That can basically cause the lift pump not to pull fuel?
I also ran a direct line to the lift pump from a cup of fuel and it wouldn't pull it out of the cup. Thanks
 
  #3  
Old 05-12-2014, 10:55 AM
Senior Member
Join Date: Jan 2008
Location:
Posts: 553
Default

If you decide to get the Mercedes part 0000900210 keep in mind that it does not have the 1.5mm cross section 5mm I.D. 8mm O-ring.

I got a O-ring locally from a BMW Motor Cycle dealer as I did not what to spend a lot of time driving aroud for agout $1.50BMW motorcycle parts 5x1.5mm O-ring, cold-start enrichener shaft, part# 13 11 1 257 819

The complete Bosch Fuel Supply/Lift Pump Kit is DGK 301 and there is a gneric version for about $10.
To locate the Kits do a internet search Bosch DGK301 or Bosch DGK 301
 
Attached Thumbnails 1985 300sd NO POWER will not rev Bad lift pump?  need help!-lift-pump-1-april-13.jpg   1985 300sd NO POWER will not rev Bad lift pump?  need help!-kit-lift-pump-valves-feb-13.jpg  
  #4  
Old 05-12-2014, 03:56 PM
Junior Member
Thread Starter
Join Date: May 2014
Location: Cumberland Gap Tn
Posts: 18
Default

Ok I will check that out. I want to be pretty sure I'm onto the problem before I take the lift pump off and tear it apart. Just seems like the problem since I've done about everything else and if there is hardly to no fuel being pulled into the primary clear filter even when pulling the fuel from a cup. Thanks
 
  #5  
Old 05-13-2014, 01:39 AM
Junior Member
Thread Starter
Join Date: May 2014
Location: Cumberland Gap Tn
Posts: 18
Default

Alright I'll just try that how do I remove the check valves? What is best to clean them with?
 
  #6  
Old 05-13-2014, 03:38 PM
Senior Member
Join Date: Jan 2008
Location:
Posts: 553
Default

When I changed the O-ring in My Fuel Supply/Lift Pump that O-ring was likey 27 years old; one of the reasons I decided to change it.
 
  #7  
Old 05-14-2014, 04:11 AM
Junior Member
Thread Starter
Join Date: May 2014
Location: Cumberland Gap Tn
Posts: 18
Default

Ok so I cleaned the check valves and have plenty of fuel in the primary filter now and the primer pump is working. But it barely idles I can put the pedal on the floor and it barely gets to 1300 rpm and that's it.. If I hold it on the floor for literally probably a minute it will finally start to gain rpms but once I let it idle it's back to the same thing.... but somehow it starts pretty alright and doesn't seem to be smoking other than the valve cover gasket is leaking. Could this be the valves need adjusting really bad cause it doesn't sound like my other 300 or could this be the injectors are about shot? I think I'm going to do an injector cleanse I've been reading about and see If that helps. It also has a gushing bad heater core that I've got to address soon. I sure hope someone chimes in on this I'm running out of ideas
 
  #8  
Old 05-16-2014, 07:33 PM
Senior Member
Join Date: Jan 2008
Location:
Posts: 553
Default

Originally Posted by benz300sd View Post
Ok so I cleaned the check valves and have plenty of fuel in the primary filter now and the primer pump is working. But it barely idles I can put the pedal on the floor and it barely gets to 1300 rpm and that's it.. If I hold it on the floor for literally probably a minute it will finally start to gain rpms but once I let it idle it's back to the same thing.... but somehow it starts pretty alright and doesn't seem to be smoking other than the valve cover gasket is leaking. Could this be the valves need adjusting really bad cause it doesn't sound like my other 300 or could this be the injectors are about shot? I think I'm going to do an injector cleanse I've been reading about and see If that helps. It also has a gushing bad heater core that I've got to address soon. I sure hope someone chimes in on this I'm running out of ideas
It would do no harm to check the Valves and adjust them if needed.

It is extremely rare but I have seen Fuel Supply/Lift Pumps were the Piston Spring was Broken. With the Spring broken the Piston does not return as far as it is supposed to and the Pump does not put out enoug flow.
I don't know if you can tell that just buy removing the Fuel Supply Pumps Fuel outlet Hose/tube and seeing what comes out or not.

There is a flow test for the Supply Pump, there is a pressure test and there is also a Vacuum Test. Of the 3 the Vacuum test is the easiest to as you get a T fitting and T into the Fuel Inlet Hose between the Fuel Supply Pump and the Plastic Primary Filter.
I don't konw if Autozone has a Vacuum Gauge on their Free Rental or not.

Can you get more than 1300rpms when you grab the Throttle Lever at the Fuel Injection Pump itself and does that leve go all the way to the Stop Screw?

The no load rpms can go over 4,500+ rpms but don't stay at that rpm long. Just long enoug to verify it can make it.

Did you try running the Engine from a seperate Container of Clean Diesel Fuel? That would bypass everthing from the Tubing on the Fender well back to the Fuel Tank.
 

Last edited by Diesel9112; 05-16-2014 at 07:37 PM.
  #9  
Old 05-19-2014, 07:55 PM
Junior Member
Thread Starter
Join Date: May 2014
Location: Cumberland Gap Tn
Posts: 18
Default

The fuel supply pump I believe is fine now the primer pump is pumping fuel into the filter all that seems normal. But you still have to hold it on the floor for atleast a minute and it will finally get over 2k and rev and will continue to Rev up as long as you don't let the rpms drop below 2k then your back to barely getting it last 13-1500... I've cleaned all this and that egr banjos lines filters ive worked the linkage by hand still no better. Is my injectors worn out you think? Should I do a injector purge on them with some type of fuel treatment? Is there a way to remove them and clean the injectors?
 
  #10  
Old 05-23-2014, 03:04 AM
Junior Member
Thread Starter
Join Date: May 2014
Location: Cumberland Gap Tn
Posts: 18
Default

Yes it still reacts the same. I have to almost hold it half throttle just to get the engine to idle halfway decent if not it will just idle and buck way down and will even die sometimes. The engine starts decent surprisingly. I'd like to get this thing figured out
 

Thread Tools
Search this Thread
Quick Reply: 1985 300sd NO POWER will not rev Bad lift pump? need help!


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.