Other Post discussion on all other models not listed above here.

2000 ML320 Electrics?

  #1  
Old 12-27-2008, 05:42 PM
Thread Starter
Join Date: Dec 2008
Posts: 1
Default 2000 ML320 Electrics?

Hello Everyone[/align]I recently purchased my 2000 ML320 and am having loads of fun with it and apart from some frustrating issues with the alarm and instrument cluster am really happy with the vehicle. I am hoping that someone from the forum can provide some insight or assistance in assisting me in rectifying the issues[/align]The Alarm[/align]2Key fobs both appear to work perfectly, they open the doors, close the doors, release the tailgate and al of the lights flash as they should be. The only problem is the alarm does not arm? I can start the vehicle no problems with the car supposebly armed. Also theLED in the centre console that should flash when the alarm is activated does not do so - it does flash wen the key is in the ignition in both position 1 & 2. Very strange and it was the LED thet led to me discovering that the vehicle was totaly unrotected. I did notice just this morning that the Alarm Horn relay is not apparent in the fuse box - unsure hether this attributes to the problem.[/align]Another issue s the instrument cluster. When you turn the key to ingnition there appears to be a delay of some 30 seconds prior to the dials activating themselves - ie the fuel dial does not move but there is a whirring noise from the tachometer which appears to shake during this 30 second inteval. This also hapens when I turn the engine off. There is a whirring noise and the tachometer needle shakes for aproximately 10 seonds. [/align]Am unsure whether the alarm and instrument cluster problems I have detailed above are somehow connected?[/align]Any advice, commentary or similar issues encountered by other and rectified will be greatly appreciated.[/align]Best regards from sunny Melbourne Australia[/align]Tony Langone[/align]
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
stuartwood
Mercedes C Class
0
11-04-2007 03:17 PM
Mawbs
General Tech
0
04-22-2007 07:25 PM
bluebirdnips
Mercedes C Class
0
03-08-2007 06:46 PM
Mawbs
General Tech
1
07-07-2005 09:45 PM
baileygb7
General Tech
0
01-07-2004 01:26 PM


Thread Tools
Search this Thread
Quick Reply: 2000 ML320 Electrics?


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.