Mercedes SLK Class All Mercedes SLK Roadsters.

Hard Top Switch

  #1  
Old 06-10-2015, 08:58 PM
Junior Member
Thread Starter
Join Date: Apr 2015
Location: New Zealand
Posts: 7
Question Hard Top Switch

I have a 1998 SLK230. The top switch flashes and every now and then an alarm goes off. Sometimes I can clear this by simply opening and closing the trunk before I drive off. Sometimes this does not work and I have to drive it as is. Obviously an intermittent problem but I have no idea how to solve it.
Need help please.
 
  #2  
Old 06-10-2015, 10:26 PM
Senior Member
Join Date: Jun 2007
Location: heaven on earth, the s. Oregon coast
Posts: 756
Default

does it make a difference whether the top is up or down?
 
  #3  
Old 06-11-2015, 05:05 PM
Junior Member
Thread Starter
Join Date: Apr 2015
Location: New Zealand
Posts: 7
Default Hard Top Switch

Winter here at the moment so only know with the top up. Seems to be permanently flashing now with the buzzer sounding after either a period of time or k's been driven.
 
  #4  
Old 06-11-2015, 08:09 PM
Junior Member
Thread Starter
Join Date: Apr 2015
Location: New Zealand
Posts: 7
Default

Have now tried it with top open, all is good. Top up same thing.
 
  #5  
Old 06-12-2015, 01:14 AM
Senior Member
Join Date: Jun 2007
Location: heaven on earth, the s. Oregon coast
Posts: 756
Default

I think it's the micro switch where the pin on the right side goes into windshield frame next to the right latch. You can see it with a flashlight. not hard to replace. look in manual to how to replace lamps in the overheads and remove the screws, remove visors, pull straight back on the cover. if one or more of the push on clips come off, just re-glue.
 

Last edited by brookings; 06-12-2015 at 01:38 AM.
  #6  
Old 06-14-2015, 04:57 PM
Junior Member
Thread Starter
Join Date: Apr 2015
Location: New Zealand
Posts: 7
Smile Hard Top Switch

Many thanks for the answer Brookings. I shall look into that when I get the time.
 
  #7  
Old 06-21-2015, 04:36 PM
Junior Member
Thread Starter
Join Date: Apr 2015
Location: New Zealand
Posts: 7
Default

Have lowered the roof then put it back up,drove it for a couple of days and all was well until I opened the boot, the light on switch will not go out and buzzer sounds every now and then as before. Lowered the roof again,then back up, all is well. Open the boot and problem returns. It must be something in the boot that is causing this.
Any ideas??????
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
tarrantb
Mercedes M Class
9
12-03-2010 01:25 PM
bernst
For Sale / Trade Classifieds
1
11-13-2007 08:56 PM
volksoholic
Diesel Discussions
3
02-03-2005 10:18 PM
560SLTucson
Mercedes SL Class
0
05-18-2004 11:27 PM


Thread Tools
Search this Thread
Quick Reply: Hard Top Switch


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.