Resetting maintenance service indicator - Mercedes Forum - Mercedes Benz Enthusiast Forums

Mercedes E Class Mercedes E320 and Mercedes E500 Sedans and Wagons.

Sponsored by:
Sponsored by:

Resetting maintenance service indicator

Reply

 
 
 
  #1  
Old 02-05-2007, 04:59 PM
Thread Starter
Join Date: Feb 2007
Posts: 1
Default Resetting maintenance service indicator

Hello all, I am a newbie to this forum, I tried searching for any posting on RESETTING the maintenance service indicator, but came up empty. Maybe I don't know how to search. Anyway, I have a '05 E320, I know quite a bit on maintaining/servicing car. I would like to work on this myself. I was wondering if anyone know how to reset the service indicator. HELP!!! someone. Thanks in advance for your help.

DC
 
Reply With Quote
  #2  
Old 02-10-2007, 09:06 PM
Join Date: Sep 2006
Location:
Posts: 20
Default RE: Resetting maintenance service indicator

late model E320... only way I know to clear it is with code reader... though I would certainly listen to any ideas put forth by the Gurus here, I'm a relative newbie.
 
Reply With Quote
  #3  
Old 02-12-2007, 03:54 PM
Join Date: Aug 2005
Location:
Posts: 22
Default RE: Resetting maintenance service indicator

ORIGINAL: dcqme

Hello all, I am a newbie to this forum, I tried searching for any posting on RESETTING the maintenance service indicator, but came up empty. Maybe I don't know how to search. Anyway, I have a '05 E320, I know quite a bit on maintaining/servicing car. I would like to work on this myself. I was wondering if anyone know how to reset the service indicator. HELP!!! someone. Thanks in advance for your help.

DC
You can go to http://www.mercedestechstore.com and download the pdf presentations under the W211 section (training files). Get the FSS+ and the W211 Service Sheet. Also, go to http://tech.bentleypublishers.com and select the MB section and look at the W211 area. There are many WIS procedures listed there that a previous member posted for myself and others -- you shoul find all you need to do all your scheduled maint.

Regards,
paul...
 
Reply With Quote
  #4  
Old 06-08-2009, 08:13 AM
Junior Member
Join Date: Jun 2009
Posts: 1
Default Mercedes E300 resetting Service A Display

Hey PaulV... thanks for the info... it worked for me in Canada like this.

1. put key into possition 1 and press the "R" (reset) button 3 times quickly. Voltage indicator is displayed.
2. use "up" and "down" arrows until you get "Service Data" display.
3. use "+" and "-" to scroll to "Confirmation". and select it using the selection button.
4. turn key to possition 2... the rest is straight forward.

Paul's suggested pdf file is of great help....
http://www.mercedestechstore.com/pdf...2008-16-02.pdf

Thanks...
 
Reply With Quote
Reply
 
 
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
dssmith45
Mercedes CLK Class
1
12-14-2010 02:01 PM
Mike C
Mercedes C Class
2
10-24-2010 05:22 PM
Ronsr1009
Mercedes M Class
1
10-15-2009 10:47 PM
acowan
Mercedes E Class
0
07-12-2009 08:03 AM
KiloVolt
Mercedes SL Class
0
01-19-2005 01:33 PM


Thread Tools
Search this Thread
Advertising
Featured Sponsors
Vendor Directory