Diesel Discussions Only diesel topics should be posted here.

06 CDI loss of power

  #1  
Old 09-19-2017, 12:38 PM
MDD
MDD is offline
Junior Member
Thread Starter
Join Date: Sep 2017
Posts: 1
Default 06 CDI loss of power

Hey guys - new to this forum and could use some help.

Got an issue with my 06 CDI. She has 260k miles. One day she was fine, the next morning I have a loss of power and a CEL. She runs ok but no boost when you hit the pedal.

Codes are:
P0243 - Turbo wastegate malfunction
P2009 - fuel water content sensor.(fuel filter)
P0489 - Exhaust gas recirculation control short to earth
P0102A - Mass or Volume Air Flow Circuit Low Input
The descriptions are what I got off the web but I'm not 100% sure for my car. At the same time, I'm started getting a low coolant alarm on the dash but the coolant level is fine.

I doubt they are all the root cause so looking for real guidance. The only true symptom is the loss of power when accelerating.

I pulled the Air intake assembly off and inspected the MAF and Turbo for any loose wiring or connectors but don't see any. I cranked it up and had my son hit the accelerator but I cannot see the turbo linkage move (I think it would have moved in the time I tried it). I've wondered if a fuse might be the issue with all the different codes.

Thanks for the advise in advance!
Mark
 
  #2  
Old 10-31-2017, 10:16 AM
ot1
ot1 is offline
Junior Member
Join Date: Mar 2007
Posts: 10
Default

Change the fuel filter first. its a $45 for the filter and the 2 hose clamps $3, and 20 minutes time DIY, you need a T20 bit too and a rag, there is no mess and you don't need to fill the filter or use a hand pump. Pull off the driver side top engine cover, the fuel filter is right there, you reuse the water sensor which pulls straight out after you remove the T20 screw. Buy the filter from Mercedes and its comes with o-rings for the sensor. You pop the old clamps with a small flat blade screwdriver (1/8"). You should buy the proper clip pliers to squeeze on the new clamps.
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
mikebran
Mercedes C Class
2
01-19-2017 12:31 AM
dazzleships
Mercedes E Class
0
04-10-2012 04:13 AM
tony jr
Diesel Discussions
3
01-22-2012 06:15 PM
cab262
Diesel Discussions
1
05-02-2010 09:11 AM
sfmorton
Mercedes M Class
3
09-13-2007 12:12 AM


Thread Tools
Search this Thread
Quick Reply: 06 CDI loss of power


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.