Driver seat won't move - Page 2 - Mercedes Forum - Mercedes Benz Enthusiast Forums

Mercedes CLK Class Mercedes CLK350 and Mercedes CLK500 Coupes and Cabriolets.

Driver seat won't move

Reply

 
 
 
  #11  
Old 06-05-2012, 05:35 PM
Junior Member
Join Date: Dec 2008
Posts: 2
Default

If you didn't get this fixed then it could be that it just needs to be reset. I had the same thing happen and there is a process for setting the seat parameters when a seat is newly fitted - this process needs to be followed. Unfortunately I cannot remember what the process is but that should be easy enough to find on here or Google.
 
Reply With Quote
  #12  
Old 09-25-2016, 09:44 PM
Junior Member
Join Date: Sep 2016
Posts: 1
Default

stang0303, What did you determine to be your power seat control problem? My 2001 CLK320 is doing the same exact thing so I assume what ever you did is what I need to do. My driver seat won't move fwd/aft and the rear part of the the up/down won't work. I removed the connector and applied 12VDC directly to the motor connector sockets and got it to move. So obviously it's not a bad motor issue, which I doubted since two simultaneous separate motor failures is not likely. I replaced the control module with an eBay used one and didn't fix it. Fuses are all OK. I hear a click below the seat when pushing the switches so I doub't the switch is bad. So anybody have any clues? I'm almost out of ideas. Door switch? I don't have a good wire schematic. Thanks guys.
 
Reply With Quote
  #13  
Old 01-18-2018, 11:09 AM
Junior Member
Join Date: Jan 2018
Posts: 1
Default Did you ever figure this out?

Did you ever figure this out? Iím having the same issue with my 03 CLK330 Convertible.Thx!-dw
Originally Posted by Patrick Hill View Post
stang0303, What did you determine to be your power seat control problem? My 2001 CLK320 is doing the same exact thing so I assume what ever you did is what I need to do. My driver seat won't move fwd/aft and the rear part of the the up/down won't work. I removed the connector and applied 12VDC directly to the motor connector sockets and got it to move. So obviously it's not a bad motor issue, which I doubted since two simultaneous separate motor failures is not likely. I replaced the control module with an eBay used one and didn't fix it. Fuses are all OK. I hear a click below the seat when pushing the switches so I doub't the switch is bad. So anybody have any clues? I'm almost out of ideas. Door switch? I don't have a good wire schematic. Thanks guys.
 
Reply With Quote
Reply
 
 
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
BenzforT
Mercedes C Class
5
03-28-2017 01:43 PM
Godfather Benz
Mercedes SL Class
2
12-25-2012 10:44 AM
weharrison
Mercedes CLK Class
8
09-01-2010 12:50 AM
Alabaster430cab
Mercedes SL Class
3
08-28-2007 11:04 PM
carsfastfredi
Mercedes SL Class
4
02-19-2007 01:21 AM


Thread Tools
Search this Thread
Advertising
Featured Sponsors
Vendor Directory