1999 ML320 transmission shifting - Mercedes Forum - Mercedes Benz Enthusiast Forums
Mercedes Benz Forums

Go Back   Mercedes Forum - Mercedes Benz Enthusiast Forums > General Mercedes Benz Forums > New Mercedes Benz Forum Members Area
Search

Reply
 
 
 
 
LinkBack Thread Tools Search this Thread
  #1  
Old 07-01-2005, 02:33 AM
 
Join Date: Jul 2005
Posts: 1
Default 1999 ML320 transmission shifting

I have a 99 ML320. A couple months ago, every couple of days the car would either not shift up into a higher gear, stuck in 2nd gear it seems, or get stuck in 3-4th gear, and will not downshift when vehicle has slowed down to a stop. This means at a stop light it would accelerate extremely slow due to the higher gear. I would then turn the car off and turn it back on, and the problem would be gone. Back to normal.

A couple of days ago, the problem has came back, but this time, it is here for good. I tried turning off and back on to no avail. So right now, it wont upshift past 2nd gear. I initially presumed it was limp mode related, but my friend says there is a code in the tranny cpu saying that it has to do with the RPM sensor. I could get the exact codes if that would help.

Have anyone else experienced this problem? If so, how was it resolved?

In checking w/the local MB dealer, the tech suggested it could be the crank sensor. As our temps have been around 92 degrees, he mentioned that extreme temps can active the problem. The air mass was replaced several days ago.
Reply With Quote
  #2  
Old 07-01-2005, 05:01 AM
sleepwalker's Avatar
Super Moderator
 
Join Date: Apr 2004
Location: Philippine Islands
Posts: 7,045
Send a message via ICQ to sleepwalker Send a message via Yahoo to sleepwalker
Default RE: 1999 ML320 transmission shifting

can you read the fault code first?

it has nothing to do with the RPM sensor for wheels and crankshaft position sensor.
__________________
support - Solar Energy
Reply With Quote
  #3  
Old 04-17-2008, 03:25 PM
 
Join Date: Apr 2008
Posts: 2
Default RE: 1999 ML320 transmission shifting

I had the same problem and the Mercedez benz dealer changed all sorts of parts without fixing the problem. I eventually took it to a foreign car mechanic who found that it was the electronic alternator. The alternator on these vehicles has a regulator thatmodifies the voltage and if it is bad will send all sorts of malfunctions to the cpu. Since having the alternator I haven't had any problems.
__________________
weshon hornsby
Reply With Quote
 
 
 
Reply

Tags
1999, 320, 99, benz, cold, forum, gear, mercedes, ml, ml320, model, problem, problems, shifting, stuck, transmission, upshift, wont


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
C240 help....auto transmission problems shifting AAmais88 Mercedes C Class 2 04-19-2007 01:21 PM
Transmission shifting late when cold, alarm making lights flash Jusmack Mercedes SLK Class 8 02-17-2007 05:57 AM
84 300D: transmission/gear shifting question redly1 Diesel Discussions 2 09-02-2005 07:01 PM
transmission shifting very rough gte811f Mercedes C Class 2 08-07-2005 02:37 AM
transmission late shifting cool Mercedes S Class 14 10-29-2004 10:44 PM

Advertising
Featured Sponsors
Vendor Directory
Our Sponsors
GetCoolParts.com
Monroe, WA 98272
360.863.0557
All times are GMT -5. The time now is 07:42 AM.

Internet Brands, Inc.