Mercedes Benz Forums


Go Back   Mercedes Forum - Mercedes Benz Enthusiast Forums > Mercedes Benz Models > Mercedes SLK Class
Sign in using an external account
Register Forgot Password?
Search

Welcome to Mercedes Forum!
Welcome to Mercedes Forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to start new topics, reply to conversations, privately message other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, join Mercedes Forum today!

Reply
 
 
 
 
LinkBack Thread Tools Search this Thread
  #1  
Old 02-09-2009, 04:11 PM
Member
 
Join Date: Dec 2005
Location: Nashville
Posts: 41
Default SLK 230 '01 model - Check Engine light on Help

My check engine light came on and the car seems to hesitate very little at low speeds some times. The OBD II code read "secondary injection system". I put some fuel injector cleaner in to see if it will help. Last time I got this after getting some bad gas and had it reset.
Any ideas?? Is it the fuel injectors?
Register today for free or log in if already registered to remove this ad!
__________________
TheBenzMan
Reply With Quote
  #2  
Old 02-09-2009, 09:23 PM
Junior Member
 
Join Date: Nov 2005
Posts: 7
Default

Sorry to hear you're having a similar problem. My SLK is performing the same but in addition to the P0410 code I also have a P0341 (CAM POS Sensor) code. I've posted a thread on this so you may want to monitor that for ideas. I'll let you know when I find the solution.

I replaced the Cam Pos Sensor ($140) and it also cleared the Sec Fuel Inj P0410 code. 2 weeks now and no repeat.

Last edited by sflankey; 02-28-2009 at 03:55 PM. Reason: Problem solved with P0341 and P0410 codes.
Reply With Quote
  #3  
Old 02-11-2009, 09:04 AM
Member
 
Join Date: Dec 2005
Location: Nashville
Posts: 41
Default

Thanks man
__________________
TheBenzMan
Reply With Quote
  #4  
Old 02-11-2009, 09:25 PM
livefreeordie's Avatar
Member
 
Join Date: Nov 2007
Location: NH
Posts: 95
Default

Quote:
Originally Posted by TheBenzMan View Post
My check engine light came on and the car seems to hesitate very little at low speeds some times. The OBD II code read "secondary injection system". I put some fuel injector cleaner in to see if it will help. Last time I got this after getting some bad gas and had it reset.
Any ideas?? Is it the fuel injectors?

Your MAF needs to be cleaned. Very simple ten min. job.
__________________
When all is said and done; more is said than done.
Reply With Quote
  #5  
Old 02-11-2009, 09:27 PM
livefreeordie's Avatar
Member
 
Join Date: Nov 2007
Location: NH
Posts: 95
Default

Quote:
Originally Posted by sflankey View Post
Sorry to hear you're having a similar problem. My SLK is performing the same but in addition to the P0410 code I also have a P0341 (CAM POS Sensor) code. I've posted a thread on this so you may want to monitor that for ideas. I'll let you know when I find the solution.
The cam sensor is aroubd $40 from a dealer and only takes a couple of min. to replace. Its located up front near the oil filter.
__________________
When all is said and done; more is said than done.
Reply With Quote
  #6  
Old 02-16-2009, 04:47 PM
Junior Member
 
Join Date: Feb 2009
Posts: 1
Default SLK 2000 Check Engine Light stays on....

The check engine light came on after I had filled the car with gas. I checked the cap and it seemed to be put on correctly. I ended up buying a new gas cap ($15) and still the light would not come off. So I decided to try patience. The car ran great, and after about 300 miles the light went off. I have not had a problem since then. Patience paid off this time, instead of running to the dealer to fix the problem immediately.
Reply With Quote
  #7  
Old 02-17-2009, 03:23 PM
Member
 
Join Date: Dec 2005
Location: Nashville
Posts: 41
Default

Thanks for the reply, do you have any pics on the location of the MAF valve for an SLK 230 ' 01? What would I use to clean it.
__________________
TheBenzMan
Reply With Quote
  #8  
Old 02-17-2009, 03:25 PM
Member
 
Join Date: Dec 2005
Location: Nashville
Posts: 41
Default

Livefreeordie, do you have any pics and what to use to clean the MAF valve?
__________________
TheBenzMan
Reply With Quote
  #9  
Old 06-10-2009, 01:52 AM
livefreeordie's Avatar
Member
 
Join Date: Nov 2007
Location: NH
Posts: 95
Default

Quote:
Originally Posted by TheBenzMan View Post
Livefreeordie, do you have any pics and what to use to clean the MAF valve?

Hay sorry it took so long to reply to your post i don't visit here much. I use CRC cleaner which you can get at any auto parts store for around $5.
__________________
When all is said and done; more is said than done.
Reply With Quote
  #10  
Old 06-13-2011, 05:56 AM
Junior Member
 
Join Date: Jan 2011
Posts: 1
Unhappy Starting problems SLK230

I think I may have similar problems on my SLK230 Kompressor, year 2003, 48k miles. Recently, it has been difficult to start but once running everything is okay. I've found fuse F2 has blown, located in the fuse box in the engine bay on top of the module which I think is called relay K3.

I also had the fault code for the cam sensor which I have replaced but I still get code PO414, listed as the Secondary Air Injection system.

I don't seem to have a fuse chart to identify F2 so I tried the obvious thing of just replacing it and it blew straight away, it's 15A.

I read a couple of threads about problems with early relay modules and so I had a close look at it but could not see anything wrong - nothing burnt and no poor solder joints.

I tried reseting the fault code but it just reappears.

I don't know if I have correctly identified the secondary air injection valves. When I trace the pipes they seem to go to the crankcase rather than the exhaust. So I think I think I might getting muddled with the crankcase breather system?

Does anyone know what the function of fuse F2 is? Can you point me to any thread that might help and are there any pictures of the secondary air system components?

Any help much appreciated.
Many thanks, John.
Reply With Quote
Old 06-13-2011, 05:56 AM
 
 
 
Reply

Tags
2000, 2001, 230, benz, cam, check, engine, light, mercedes, position, reset, resetting, sensor, slk, slk230


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Advertising
Featured Sponsors
Vendor Directory
Our Sponsors
GetCoolParts.com
Monroe, WA 98272
360.863.0557
All times are GMT -5. The time now is 03:12 PM.

Internet Brands, Inc.