Mercedes Benz Forums


Go Back   Mercedes Forum - Mercedes Benz Enthusiast Forums > Mercedes Benz Models > Mercedes M Class
Sign in using an external account
Register Forgot Password?
Search

Welcome to Mercedes Forum!
Welcome to Mercedes Forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to start new topics, reply to conversations, privately message other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, join Mercedes Forum today!

Reply
 
 
 
 
LinkBack Thread Tools Search this Thread
  #1  
Old 01-09-2009, 01:52 PM
Junior Member
 
Join Date: Jan 2009
Posts: 6
Default Possible Bad Key-DAS problem?

Just purchased 1998 ML320 and won't start. Vehicle has been laid up for about a year and during that time the battery was ran down and charged a couple of times and vehicle started, but it has not been started in several months. Charged battery and even tried boosting , all to no avail. The engine cranks, and even catches on occasion , and then just dies. All cluster lights come on and is showing RPM movement the odd time that it does catch for a brief moment.Neither of the three keys I have will work, although the remote locking function is fine, re-synched the keys, no go. It is giving a code of P1570, indicating a communication error between ignition and ECM, conclusionAS is not recognizing either of the keys....or a faulty DAS ring........but....also neither of the keys turned to position II will give the quick illumination of the security light.......which leads me to conclude that all the keys are bad........is that possible? Or just really bad luck?

If so, can these keys be reprogrammed without the vehicle at the dealership......or do I have to purchase new keys and tow the vehicle to the "stealer".

Or, could it be something totally different.........faulty DAS.

Is there a quick fix? Can I disable the antitheft to by-pass this issue. Any advice greatly appreciated.
Register today for free or log in if already registered to remove this ad!
Reply With Quote
  #2  
Old 07-11-2009, 01:53 AM
Junior Member
 
Join Date: Jul 2009
Posts: 1
Default

i have the same car I had the same problem with 2 of the keys.be careful mercedes only makes 8 keys per lock
Reply With Quote
  #3  
Old 07-11-2009, 08:45 AM
chassis221's Avatar
Senior Member
 
Join Date: Feb 2007
Location: Philadelphia, Pa
Posts: 2,654
Default

its not a key program issue, it should still start your car. could be the ring around the ignition where you put in the key. its sort of an antenna that recognises the key. maybe you have a fuel pressure issue?
__________________
Philadelphia, Pa
Certified MB Master 13yrs
Valentine 1 Radar and Laser Locator
Galaxy DX 95T Export radio
Reply With Quote
Old 07-11-2009, 08:45 AM
 
 
 
Reply

Tags
1998, battery, benz, bypass, code, das, disable, error, key, keydas, mercedes, ml320, p1570, problem, problems, start


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Advertising
Featured Sponsors
Vendor Directory
Our Sponsors
GetCoolParts.com
Monroe, WA 98272
360.863.0557
All times are GMT -5. The time now is 04:49 AM.

Internet Brands, Inc.



SEO by vBSEO ©2010, Crawlability, Inc.