ML500 2002 brake problem ! - Mercedes Forum - Mercedes Benz Enthusiast Forums
Mercedes Benz Forums

Go Back   Mercedes Forum - Mercedes Benz Enthusiast Forums > Mercedes Benz Models > Mercedes M Class

LinkBack Thread Tools Search this Thread
Old 02-06-2007, 01:05 AM
Join Date: Feb 2007
Posts: 2
Default ML500 2002 brake problem !

Hi i have 2002 ML500 im having braking problems... and i would like to know if anybody has the same problem as me... this is the problem... when you press the brake its like it goes deep and doesnt brake good it doesnt make that back preassure... so you have to press it real hard to make the truck stop. .the car has been taken to the dealer and they just changed the fluid and said nothing happens... it doesnt leak anywhere.. does anyone has some idea of what this could be? thanks
Reply With Quote
Old 02-06-2007, 04:26 PM
Join Date: Apr 2004
Posts: 15
Default RE: ML500 2002 brake problem !

Dealer is not very good if they cannotfind the problem, choose a brake specialist. Sounds like calipers may be frozen or pads too thin? I have mine done at a brake shop that does all vehicles not just Mercedes. He has been very good so far. Also have the Master Cylinder checked, it provides the pressure from the pedal and should have a vacuum assist as well that5 may be suspect.
Reply With Quote
Old 02-06-2007, 09:31 PM
Join Date: Feb 2007
Posts: 2
Default RE: ML500 2002 brake problem !

Ok. thanks a lot.. ill try to take it to a brake specialist tomorrow!
Reply With Quote
Old 02-08-2007, 10:51 PM
Join Date: Aug 2005
Posts: 172
Send a message via AIM to MBZTech Send a message via Yahoo to MBZTech
Default RE: ML500 2002 brake problem !

This happens a lot on ML's....usually happens after someone replaces brake pads....Dive fast and step on the brake really hard...try to get the ABS pump to turn on and build pressure.....You usually have to repeat this many times to get the pump to build up pressure again....Also keep an eye on your brake fluid level...The fluid might be leaking from your master cylinder into your brake booster...
MBZ Technician at Smythe European!
Reply With Quote
Old 03-05-2007, 04:01 PM
Join Date: Feb 2007
Posts: 5
Default RE: ML500 2002 brake problem !

I recently bought a used 2002 ML320 Sport. The vehicle has had a soft brake petal since Ipicked it up.
I followed your instructions above as far as finding some empty highway, getting up to speed (around 60 Mph) and braking very hard. Amazingly, it worked perfectly! The petal is firm and the brakes seem to work much better than before. I was ready to do a front brake job to get a better petal feel, but now will wait for the pads to wear down. Thanks again!
Reply With Quote

Similar Threads
Thread Thread Starter Forum Replies Last Post
Brake Wear Light on 06 ML500 reset question sales406 Mercedes M Class 1 08-02-2012 09:10 PM
Cannot move 2003 ML500 with no brake pedal pressure. Abe Simpson Mercedes M Class 4 10-10-2011 01:55 PM
2002 ML500 - Brake booster / Lock activator HDYLUN General Tech 0 11-30-2009 11:29 PM
Installing Tekonsha brake assist on ML500 antares1944 Mercedes M Class 0 09-11-2009 10:46 PM
2001 ml500 brake squeal... shannoninocala General Tech 0 03-05-2008 06:54 PM

02, 2002, abs, benz, booster, brake, fluid, leak, leaking, mb, mercedes, ml500, oil, problems, pump, recommended, tools

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -5. The time now is 01:23 PM.