Mercedes Benz Forums


Go Back   Mercedes Forum - Mercedes Benz Enthusiast Forums > Mercedes Benz Models > Mercedes M Class
Sign in using an external account
Register Forgot Password?
Search

Welcome to Mercedes Forum!
Welcome to Mercedes Forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to start new topics, reply to conversations, privately message other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, join Mercedes Forum today!

Reply
 
 
 
 
LinkBack Thread Tools Search this Thread
  #1  
Old 02-06-2007, 12:05 AM
 
Join Date: Feb 2007
Posts: 2
Default ML500 2002 brake problem !


Hi i have 2002 ML500 im having braking problems... and i would like to know if anybody has the same problem as me... this is the problem... when you press the brake its like it goes deep and doesnt brake good it doesnt make that back preassure... so you have to press it real hard to make the truck stop. .the car has been taken to the dealer and they just changed the fluid and said nothing happens... it doesnt leak anywhere.. does anyone has some idea of what this could be? thanks
Register today for free or log in if already registered to remove this ad!
Reply With Quote
  #2  
Old 02-06-2007, 03:26 PM
 
Join Date: Apr 2004
Location:
Posts: 15
Default RE: ML500 2002 brake problem !

Dealer is not very good if they cannotfind the problem, choose a brake specialist. Sounds like calipers may be frozen or pads too thin? I have mine done at a brake shop that does all vehicles not just Mercedes. He has been very good so far. Also have the Master Cylinder checked, it provides the pressure from the pedal and should have a vacuum assist as well that5 may be suspect.
Reply With Quote
  #3  
Old 02-06-2007, 08:31 PM
 
Join Date: Feb 2007
Posts: 2
Default RE: ML500 2002 brake problem !

Ok. thanks a lot.. ill try to take it to a brake specialist tomorrow!
Reply With Quote
  #4  
Old 02-08-2007, 09:51 PM
 
Join Date: Aug 2005
Location:
Posts: 172
Send a message via AIM to MBZTech Send a message via Yahoo to MBZTech
Default RE: ML500 2002 brake problem !

This happens a lot on ML's....usually happens after someone replaces brake pads....Dive fast and step on the brake really hard...try to get the ABS pump to turn on and build pressure.....You usually have to repeat this many times to get the pump to build up pressure again....Also keep an eye on your brake fluid level...The fluid might be leaking from your master cylinder into your brake booster...
__________________
MBZ Technician at Smythe European!
Reply With Quote
  #5  
Old 03-05-2007, 03:01 PM
 
Join Date: Feb 2007
Posts: 5
Default RE: ML500 2002 brake problem !

MBZTech,
I recently bought a used 2002 ML320 Sport. The vehicle has had a soft brake petal since Ipicked it up.
I followed your instructions above as far as finding some empty highway, getting up to speed (around 60 Mph) and braking very hard. Amazingly, it worked perfectly! The petal is firm and the brakes seem to work much better than before. I was ready to do a front brake job to get a better petal feel, but now will wait for the pads to wear down. Thanks again!
JP
Reply With Quote
Old 03-05-2007, 03:01 PM
 
 
 
Reply

Tags
02, 2002, abs, benz, booster, brake, fluid, leak, leaking, mb, mercedes, ml500, oil, problems, pump, recommended, tools


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Advertising
Featured Sponsors
Vendor Directory
Our Sponsors
GetCoolParts.com
Monroe, WA 98272
360.863.0557
All times are GMT -5. The time now is 03:13 AM.

Internet Brands, Inc.



SEO by vBSEO ©2010, Crawlability, Inc.