ML320 heater unit not working - Mercedes Forum - Mercedes Benz Enthusiast Forums
Mercedes Benz Forums

Go Back   Mercedes Forum - Mercedes Benz Enthusiast Forums > Mercedes Benz Models > Mercedes M Class
Search

Reply
 
 
 
 
LinkBack Thread Tools Search this Thread
  #1  
Old 01-30-2008, 06:28 PM
 
Join Date: Jan 2008
Posts: 1
Default ML320 heater unit not working

Hi Guy's - I have a 00' ML320 - and I cannot get the heater to work. The fuses are fine, the relay is working ( already had replaced with new one by dealer ), the water is hot, the blower motor operates. When I select the heater via the temp **** and set the vents to foot and windshield, and turn on the blower, it blows ambient temp air. When the temp **** is changed to cool and vents set for dash it blows super cold air. Problem is the mornings have the windshield iced and the interior cold, and I cannot get the heater/windshield defroster to operate - Blow hot air. Anyone with help it's appreciated. It's my only vehicle and I can't afford to have it spend a day or two at the dealer awaiting inspection. Thanks
Reply With Quote
  #2  
Old 02-08-2008, 09:45 PM
Member
 
Join Date: May 2007
Location: parker, CO
Posts: 82
Default RE: ML320 heater unit not working

THERE IS A AUX. WATER PUMP THAT SUPPLIES WATER TO THE HEATER CORE. IT IS RIGHT NEXT TO THE BATTERY. THIS FEEDS A GOOD SUPPLY OF WATER TO THE HEATER CORE TO HELP HEAT UP CAR FASTER ON COLD MOURNINGS. YOU SHOULD BEABLE FEEL THE PUMP WORKING WHEN THE CAR IS STARTED FIRST THING IN THE MOURNING, WITH THE HEATER ON.BEST OF LUCK.
Reply With Quote
 
 
 
Reply

Tags
320, blower, blows, control, controls, heat, heater, heating, mercedes, ml, ml320, motor, problem, work, working


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
s320 will not start, heating stopped working lights on dash not working help patricknif Mercedes S Class 0 03-04-2012 06:38 AM
Keyless not working not key not fuse Paul Dalton General Tech 0 02-07-2012 02:37 PM
1985 300D California EGR Control Unit / Tach and AC not working killo1 Diesel Discussions 1 06-14-2009 06:21 PM
Heater not working correctly. Madlions Mercedes C Class 0 10-10-2006 05:14 PM
AC Heater FAN Not Working S600 mikem9 Mercedes S Class 1 06-10-2005 10:56 AM

Advertising
Featured Sponsors
Vendor Directory
Our Sponsors
GetCoolParts.com
Monroe, WA 98272
360.863.0557
All times are GMT -5. The time now is 09:28 AM.