Mercedes Benz Forums


Go Back   Mercedes Forum - Mercedes Benz Enthusiast Forums > Mercedes Benz Models > Mercedes M Class
Sign in using an external account
Register Forgot Password?
Search

Welcome to Mercedes Forum!
Welcome to Mercedes Forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to start new topics, reply to conversations, privately message other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, join Mercedes Forum today!

Reply
 
 
 
 
LinkBack Thread Tools Search this Thread
  #1  
Old 10-29-2007, 03:39 PM
 
Join Date: Oct 2007
Posts: 1
Default heated seats not working

I have an ML320 and recently both the driver and passenger seat heaters are not working. The switch light comes on and stays on as usual but the seats do not get warm. The chair pad and back are not getting warm on either seat. I tried to check the fuses but couldn't find one labeled seat heater. Does anyone have any suggestions or have had this issue before? I am trying to avoid going to the dealer as it is not close to my home.
Register today for free or log in if already registered to remove this ad!
__________________
Natalie
Reply With Quote
Old 10-29-2007, 03:39 PM
 
 
 
Reply

Tags
2001, 2007, 320, benz, dont, e55, heated, mercedes, ml, ml320, seat, seats, work, working


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Advertising
Featured Sponsors
Vendor Directory
Our Sponsors
GetCoolParts.com
Monroe, WA 98272
360.863.0557
All times are GMT -5. The time now is 10:15 PM.

Internet Brands, Inc.



SEO by vBSEO ©2010, Crawlability, Inc.