Mercedes Benz Forums


Go Back   Mercedes Forum - Mercedes Benz Enthusiast Forums > Mercedes Benz Models > Mercedes M Class
Sign in using an external account
Register Forgot Password?
Search

Welcome to Mercedes Forum!
Welcome to Mercedes Forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to start new topics, reply to conversations, privately message other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, join Mercedes Forum today!

Reply
 
 
 
 
LinkBack Thread Tools Search this Thread
  #1  
Old 01-20-2010, 07:23 PM
Junior Member
 
Join Date: Jun 2006
Posts: 27
Question 2001 ML320 Key Remote stopped working...best solution?

Hi, all
I have three keys form my 2001 ML320 but only one worked with full functionality and the others didn't. Once my third key stopped working, I finally read the manual and found that you can try re-syncing if the remote didn't work. So I tried it by key in ignition to 2, then key out, the press unlock button five times while holding lock button within 10 seconds when pulled out and when I press lock or unlock button, I see that my car locks or unlocks indicating there's connection from the key to the car, but it only works once. Then the key wouldn't work again. I tried this with other two keys (the others that I thought it broke), and it does same thing.
So there is connection, but no more than that.

I went to the dealer to if there is a solution, and as I heard it before, my service manager tells me "get a new key for $375" Now I am upset that I need to put out such $$ for inferior product that goes bad continuously as I already bought a new key 3 years ago.

I googled a little to see if there's a solution and found it could be AAM problem (What is AAM?) which will cost around $600. or get seperate alarm......

If replacing AAM enables my all three keys, I just might do that, but I want to make sure before I proceed. Does anyone know about this? or is there a firm solution for this key thing.....

Thanks in advance.
Register today for free or log in if already registered to remove this ad!
__________________
2001 ML320 125,000mi
2004 E320 60,000mi
Reply With Quote
  #2  
Old 01-22-2010, 12:33 PM
mbenz80's Avatar
Senior Member
 
Join Date: Jan 2005
Location: USA Chicago
Posts: 429
Default

Hi Todesto,
you are not finalizing your programing. That is why they are working but only ones. Your keys are OK.
With all doors closed:
1. turn key to pos. 2 then back to pos. 0 and remove it.
2. within 10 sec. press and hold lock button.
3. Now push unlock 5 times while still pressing down lock button.
4. Release lock button.
You came all the way to this point but there is one more step to re-synchronization.
5. PRESS TAIL GATE BUTTON TO COMPLETE SYNCHRONIZATION.
This last step is not mentioned at all in my original 1999 ML320 owner's manual.
But it workes, I got two remotes working for my Ml thisway.
Bernard
__________________
1999 ML320 211K miles
2003 Lexus GX470 272K miles
1999 Chrysler LHS 86K miles
2001 Chrysler Concorde 71K miles
1980 280SE EURO W126 156K miles 142mph top speed SOLD
1984 300D TURBO DIESEL W123 SOLD
Reply With Quote
  #3  
Old 01-22-2010, 05:22 PM
Junior Member
 
Join Date: Jun 2006
Posts: 27
Default

Thanks, but no luck. I tired it but won't do anything.
Is 1999 and 2001 model same?
__________________
2001 ML320 125,000mi
2004 E320 60,000mi
Reply With Quote
  #4  
Old 01-26-2011, 12:34 AM
Junior Member
 
Join Date: Jan 2011
Location: Albany, Oregon
Posts: 2
Default Thanks So much Benz80!

I just purchased a 2000 ML320 and one of the keys I got would not work.
I tried several instructions to reprogram and nothing worked until I read your post and tried that last detail about the tailgate button.
It worked like a charm.
Saved me a lot of money.
Thanks Again!
Reply With Quote
  #5  
Old 12-14-2011, 10:24 PM
Junior Member
 
Join Date: Dec 2011
Posts: 4
Thumbs up

Quote:
Originally Posted by mbenz80 View Post
Hi Todesto,
you are not finalizing your programing. That is why they are working but only ones. Your keys are OK.
With all doors closed:
1. turn key to pos. 2 then back to pos. 0 and remove it.
2. within 10 sec. press and hold lock button.
3. Now push unlock 5 times while still pressing down lock button.
4. Release lock button.
You came all the way to this point but there is one more step to re-synchronization.
5. PRESS TAIL GATE BUTTON TO COMPLETE SYNCHRONIZATION.
This last step is not mentioned at all in my original 1999 ML320 owner's manual.
But it workes, I got two remotes working for my Ml thisway.
Bernard
Thank you so much! Worked perfectly on my 2001 ML320.
Reply With Quote
  #6  
Old 09-08-2012, 01:15 PM
Junior Member
 
Join Date: Sep 2012
Posts: 2
Default Thanks

MBENZ80

Thank You. The instructions in the owners manual did not work. Neither did many other solutions that I found on the Net. However, yours worked perfectly.
I am now a happy Benz owner.
Reply With Quote
  #7  
Old 06-29-2013, 10:02 PM
Junior Member
 
Join Date: Mar 2013
Posts: 1
Default

Works like a charm!!! Thanks!
Reply With Quote
  #8  
Old 08-24-2013, 11:54 PM
Junior Member
 
Join Date: Aug 2013
Posts: 1
Default

im having the same problem, any solutions?
Reply With Quote
  #9  
Old 12-30-2013, 10:22 PM
Junior Member
 
Join Date: Dec 2013
Posts: 2
Default

Same Problem!!!! The Trunk Lock doesnt fix it for me.

It flashes and thats it. If I press the Trunk lock after releasing the Lock button, it just unlocks the trunk once and thats it.

Please help.
Reply With Quote
  #10  
Old 01-02-2014, 07:38 PM
Junior Member
 
Join Date: Dec 2013
Posts: 2
Default

Quote:
Originally Posted by babbar187 View Post
same problem!!!! The trunk lock doesnt fix it for me.

It flashes and thats it. If i press the trunk lock after releasing the lock button, it just unlocks the trunk once and thats it.

Please help.
bump??
Reply With Quote
Old 01-02-2014, 07:38 PM
 
 
 
Reply

Tags
2001, 320, aclass, alarm, benz, isnt, key, keys, mercedes, ml, ml320, remote, stop, synchronize, working


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Advertising
Featured Sponsors
Vendor Directory
Our Sponsors
GetCoolParts.com
Monroe, WA 98272
360.863.0557
All times are GMT -5. The time now is 12:55 PM.

Internet Brands, Inc.



SEO by vBSEO ©2010, Crawlability, Inc.