Mercedes Benz Forums


Go Back   Mercedes Forum - Mercedes Benz Enthusiast Forums > Mercedes Benz Models > Mercedes E Class
Sign in using an external account
Register Forgot Password?
Search

Welcome to Mercedes Forum!
Welcome to Mercedes Forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to start new topics, reply to conversations, privately message other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, join Mercedes Forum today!

Reply
 
 
 
 
LinkBack Thread Tools Search this Thread
  #1  
Old 10-17-2010, 04:30 PM
Junior Member
 
Join Date: Oct 2010
Posts: 4
Default 95 E320 won't go into reverse

I have never owned a Mercedes and got this one with 147K on it. One owner, an old man drove since new. Great looking car, and drives great but now I am experiencing little problems, such as the freaking car will not go into reverse. Transmission fluid seems good. Any ideas?
Register today for free or log in if already registered to remove this ad!
Reply With Quote
  #2  
Old 10-17-2010, 05:36 PM
chassis221's Avatar
Senior Member
 
Join Date: Feb 2007
Location: Philadelphia, Pa
Posts: 2,666
Default

try moving the shift lever up or down slightly to P or N...mabe the linkage is messed up. or you could have someother more costly problems
__________________
Philadelphia, Pa
Certified MB Master 14yrs
Valentine 1 Radar and Laser Locator 3.893
Galaxy DX 95T Export radio
Mobius Dash Cam
Waze
Reply With Quote
  #3  
Old 10-17-2010, 05:55 PM
Junior Member
 
Join Date: Oct 2010
Posts: 4
Default

Quote:
Originally Posted by chassis221 View Post
try moving the shift lever up or down slightly to P or N...mabe the linkage is messed up. or you could have someother more costly problems
Probably the later knowing my luck. I forgot to add that it would only go into 2nd. Have been outside messing with it and now it goes through all the gears just fine.
Reply With Quote
  #4  
Old 06-25-2011, 09:20 PM
Junior Member
 
Join Date: Jun 2011
Posts: 1
Default

My car is having the same problem. Its a '95 E320 as well. We just put in new transmission oil but it still won't work. It does everything But go into reverse. Just wondering if you ever got your problem fixed?
Reply With Quote
Old 06-25-2011, 09:20 PM
 
 
 
Reply

Tags
320, 95, benz, clk, e300, e300d, e320, mercedes, mercedesbenz, mlk, reverse, shift, t, transmission, wont


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Advertising
Featured Sponsors
Vendor Directory
Our Sponsors
GetCoolParts.com
Monroe, WA 98272
360.863.0557
All times are GMT -5. The time now is 03:20 AM.

Internet Brands, Inc.