Mercedes Benz Forums


Go Back   Mercedes Forum - Mercedes Benz Enthusiast Forums > Mercedes Benz Models > Mercedes E Class
Sign in using an external account
Register Forgot Password?
Search

Welcome to Mercedes Forum!
Welcome to Mercedes Forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to start new topics, reply to conversations, privately message other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, join Mercedes Forum today!

Reply
 
 
 
 
LinkBack Thread Tools Search this Thread
  #1  
Old 05-06-2008, 06:35 PM
 
Join Date: May 2008
Posts: 1
Default 2004 E320 No Interior Heat

I know it's spring but the heater seems to have stopped working, no matter what tempI set the controls on, 72 degrees to max still no heat (both sides). I encountered this problem about 4 months ago but it only occurred for about 3 hours. This problem has lingered for a week and counting.

I've read another post some time back describing this same problem i believe and they said it was an actuator or valve near the heater core...it was somewherein the windshield wiper bay area.

Question, how doI determine what the problem is? and if it's the actuator (valve) whatever you call it, what's the part number.

thanks for any info...nothing worse than a beautiful car and no heat.

Frustrated
Register today for free or log in if already registered to remove this ad!
Reply With Quote
  #2  
Old 05-06-2008, 07:14 PM
chassis221's Avatar
Senior Member
 
Join Date: Feb 2007
Location: Philadelphia, Pa
Posts: 2,666
Default RE: 2004 E320 No Interior Heat

yes it is that valve under the wiper. heat switch over valve
__________________
Philadelphia, Pa
Certified MB Master 14yrs
Valentine 1 Radar and Laser Locator 3.893
Galaxy DX 95T Export radio
Mobius Dash Cam
Waze
Reply With Quote
  #3  
Old 05-06-2008, 10:30 PM
Banned
 
Join Date: May 2007
Location:
Posts: 1,057
Default RE: 2004 E320 No Interior Heat

What is your engine temp 80-90c?
have you checked the coolant level?
run the diagnostics
http://www.eclassbenz.com/node/27
post the values 1-8 and the errors.
fuse or relay or changeover valve(there was a tech service bulletin so dealer may have a recall on the valve*call and ask could be bad ,but I dont have a fuse list for your year.
part #A2118320584 valve
ohlord
Reply With Quote
Old 05-06-2008, 10:30 PM
 
 
 
Reply

Tags
2004, 320, a2118320584, changeover, class, e320, heat, heater, location, mecedez, mercedes, mercedez, part, problems, switchover, valve


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Advertising
Featured Sponsors
Vendor Directory
Our Sponsors
GetCoolParts.com
Monroe, WA 98272
360.863.0557
All times are GMT -5. The time now is 06:21 PM.

Internet Brands, Inc.