98 c230 problem in need of help. - Mercedes Forum - Mercedes Benz Enthusiast Forums


Reply
 
 
 
Thread Tools Search this Thread
  #1  
Old 02-17-2017, 12:53 AM
Junior Member
Thread Starter
 
Join Date: Feb 2017
Posts: 1
Default 98 c230 problem in need of help.

Hello my issue is When im driving my c230 the car bogs out if going past 55mph . Im thinking its the mass air flow sensor.
But im not 100% sure car runs good throws me a jerk once in a while putting it in gear but dont think its the tranny because it hasnt just shot on me and it dosent jolt at stops like its fighting to stay on ...my car runs smooth but sounds like it runnig rough or high .any advice is much appreciated.

Last edited by Corey Rocha; 02-17-2017 at 01:21 AM.
Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
1998 Mercedes C230-strange problem-need help jrmaricic Mercedes C Class 0 02-16-2008 11:05 PM
c230 K (2004) Radio Problem!! Need help Furnier Mercedes C Class 3 10-24-2007 05:56 PM
Help Help Help /locking problem/window problem legenesepimp Mercedes S Class 8 11-04-2005 01:36 PM
NEED HELP FAST, NEED HELP FAST!!!!!!! 87300eamg Mercedes E Class 2 10-12-2005 09:37 AM
New here and need help with a '98 C230? Fox Mercedes C Class 2 08-13-2004 02:02 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 03:07 PM.