Mercedes Benz Forums


Go Back   Mercedes Forum - Mercedes Benz Enthusiast Forums > Mercedes Benz Models > Mercedes C Class
Sign in using an external account
Register Forgot Password?
Search

Welcome to Mercedes Forum!
Welcome to Mercedes Forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to start new topics, reply to conversations, privately message other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, join Mercedes Forum today!

Reply
 
 
 
 
LinkBack Thread Tools Search this Thread
  #1  
Old 05-03-2011, 08:03 PM
Junior Member
 
Join Date: Mar 2008
Posts: 8
Default 2003 c230 won't lock doors

The key fob will start the car but will not lock or unlock the doors the panic button will not work. Just replaced the batteries but didnt help. Anyone else have this problem.
Register today for free or log in if already registered to remove this ad!
Reply With Quote
  #2  
Old 05-03-2011, 08:10 PM
chassis221's Avatar
Senior Member
 
Join Date: Feb 2007
Location: Philadelphia, Pa
Posts: 2,666
Default

first is the red light lighting on the remote when you push buttons? could be the anteena on the back window. is it tinted?
__________________
Philadelphia, Pa
Certified MB Master 14yrs
Valentine 1 Radar and Laser Locator 3.893
Galaxy DX 95T Export radio
Mobius Dash Cam
Waze
Reply With Quote
  #3  
Old 05-04-2011, 01:04 PM
Junior Member
 
Join Date: May 2011
Posts: 1
Unhappy similar problem on C240 estate

yep, I have to take the key out to manually unlock driver door (central not working) but electronic fob does start ignition. There is not indicator light on key fob and the manual central lock button on the dashboard works, as does the automatic locking when car reaches 9mph. Does this most of the time now but does, once in a while, work again!
Reply With Quote
  #4  
Old 05-04-2011, 04:23 PM
Junior Member
 
Join Date: Mar 2008
Posts: 8
Default

Yes the red light is blinking and yes just had the car retinted sat. never knew the antenna was in the back window thought it was infared. Where is the antenna located at in the window or is it part of the defrost?
Reply With Quote
  #5  
Old 05-04-2011, 05:35 PM
chassis221's Avatar
Senior Member
 
Join Date: Feb 2007
Location: Philadelphia, Pa
Posts: 2,666
Default

above the rear glass under the headliner. if you look under the headliner by pulling it down a little youll see a black plastic piece across the top of the glass that is your "com bar" antenna. this is for a sedan not a coupe. if you have a coupe the combar is above the glass in the reat lid.
no remote locks are radio frequency but can use infrared if needed. so if you got tint that is your problem.
__________________
Philadelphia, Pa
Certified MB Master 14yrs
Valentine 1 Radar and Laser Locator 3.893
Galaxy DX 95T Export radio
Mobius Dash Cam
Waze
Reply With Quote
  #6  
Old 05-05-2011, 02:57 AM
Junior Member
 
Join Date: Mar 2008
Posts: 8
Default

Thanks for the info will take care of that problem
Reply With Quote
  #7  
Old 09-21-2012, 11:35 AM
Junior Member
 
Join Date: Sep 2012
Location: Norfolk
Posts: 5
ronnie baker ron baker
Default central locking

Quote:
Originally Posted by cario View Post
yep, I have to take the key out to manually unlock driver door (central not working) but electronic fob does start ignition. There is not indicator light on key fob and the manual central lock button on the dashboard works, as does the automatic locking when car reaches 9mph. Does this most of the time now but does, once in a while, work again!
I have the identical problem , fob works when it feels like it, checked all fuses and central locking works on dash, no red light on fob though?

Whats next to check please?
Reply With Quote
  #8  
Old 09-21-2012, 02:34 PM
Junior Member
 
Join Date: Sep 2012
Location: Norfolk
Posts: 5
ronnie baker ron baker
Default

Has anyone fixed this problem ?
Reply With Quote
Old 09-21-2012, 02:34 PM
 
 
 
Reply

Tags
2003, c230, care, fob, infrared, key, keyfob, lock, mercedes, open, tinted, unlock, windows, wont, work


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Advertising
Featured Sponsors
Vendor Directory
Our Sponsors
GetCoolParts.com
Monroe, WA 98272
360.863.0557
All times are GMT -5. The time now is 12:51 PM.

Internet Brands, Inc.



SEO by vBSEO ©2010, Crawlability, Inc.