Mercedes Benz Forums


Go Back   Mercedes Forum - Mercedes Benz Enthusiast Forums > Mercedes Benz Models > Mercedes C Class
Sign in using an external account
Register Forgot Password?
Search

Welcome to Mercedes Forum!
Welcome to Mercedes Forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to start new topics, reply to conversations, privately message other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, join Mercedes Forum today!

Reply
 
 
 
 
LinkBack Thread Tools Search this Thread
  #1  
Old 12-13-2008, 12:10 PM
Junior Member
 
Join Date: Dec 2008
Posts: 2
Default 1996 c 220 rough idle problem

Just got this car..has high miles...260,132...but in great shape all highway miles..only problem is at idle..in drive or reverse it idles rough....really rough in reverse..whole car shakes...after its warm its not so bad in drive.still there..but still in reverse its still bad...runs great as long as its not at idle...also seems to idle low to me....previous owner had injectors cleaned and new plugs intstalled in the past few months...any ideas you guys can give me would be great..I'm a first time mercedes owner
Register today for free or log in if already registered to remove this ad!
Reply With Quote
  #2  
Old 12-14-2008, 10:46 AM
Senior Member
 
Join Date: Feb 2008
Posts: 123
Default RE: 1996 c 220 rough idle problem

1. Air filter clogged,
2. Vacuum leak at the throttle body, inlet manifold or associated hoses.
3. Worn, faulty or incorrectly-gapped spark plugs.
4. Uneven or low cylinder compressions.
5. Camshaft lobes worn.
6. Timing chain incorrectly fitted.
7. Blocked injector-fuel injection system faulty.
Reply With Quote
  #3  
Old 07-24-2011, 07:27 PM
Junior Member
 
Join Date: Jul 2011
Posts: 2
Default

Hello idk if this would help anyone but i figured id ask here since chrysler own jeep and mercedes.

My 89 4.0 renix cherokee does that same thing with only 80 thou on it been doin this for a couple years and i havent been able to tackle it ive replaced a bunch of sensors .

Still tac bounces sometimes from 1000 to 900 rpm others right down to 400 rpm.

In reverse when i hit the pedal to fast it will die in park if i hit the gas too quick up to 2500 rpm and let off the pedal it will drop right down to like 100 rpm and almost die then come back.

Almost sounds like this problem your having
Reply With Quote
  #4  
Old 07-27-2011, 07:10 PM
Junior Member
 
Join Date: Jul 2011
Posts: 2
Default

How can one confuse a cavilier with a jeep? That is so insulting That would be like calling an E class a reliant k car.
Reply With Quote
  #5  
Old 08-02-2011, 01:45 PM
Junior Member
 
Join Date: Jul 2011
Posts: 2
Default

Steve,
Had the same problem, I replaced the Maxflow Sensor (about $50.00 on Ebay) it fixed my problem. You can do this repair yourself it's right on the top of the motor to the left.
Hope this helps you out.

Last edited by motorradguy; 08-02-2011 at 01:48 PM.
Reply With Quote
Old 08-02-2011, 01:45 PM
 
 
 
Reply

Tags
1996, 2008, 220, benz, body, breaking, c220, c300, erratic, idle, mercedes, problems, rough, throttle, unsteady, vibrates


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Advertising
Featured Sponsors
Vendor Directory
Our Sponsors
GetCoolParts.com
Monroe, WA 98272
360.863.0557
All times are GMT -5. The time now is 03:11 AM.

Internet Brands, Inc.



SEO by vBSEO ©2010, Crawlability, Inc.