Mercedes Benz Forums


Go Back   Mercedes Forum - Mercedes Benz Enthusiast Forums > General Mercedes Benz Forums > General Tech
Sign in using an external account
Register Forgot Password?
Search

Welcome to Mercedes Forum!
Welcome to Mercedes Forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to start new topics, reply to conversations, privately message other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, join Mercedes Forum today!

Reply
 
 
 
 
LinkBack Thread Tools Search this Thread
  #1  
Old 10-27-2010, 12:07 PM
Junior Member
 
Join Date: Oct 2010
Posts: 3
Default esp, bas, abs light on all time

i have problems with the abs system on my mercedes s500 year 2000.i get this message in the dash- esp , bas, abs, visit workshop. the abs light is on all the time. can anyone help with any sugestions. i had the car to the garage and was plugged in the tester and it came up - solenoid valve relay in short circuit-.anyone knows where the relay is situated and how it looks.many thanks.
Register today for free or log in if already registered to remove this ad!
Reply With Quote
  #2  
Old 03-31-2011, 10:24 AM
Junior Member
 
Join Date: Mar 2011
Posts: 1
Default

I am having exactly the same problem with a C200 of the same year and need the same advice if anyone can help?
Reply With Quote
  #3  
Old 04-01-2011, 12:54 PM
Junior Member
 
Join Date: Oct 2010
Posts: 3
Default regarding esp, bas, abs lights on -to steve 36

the thing is you have to pin point the problem.my problem was the two wires from the esp module, they were pulled out.
you got to start from the abs sensors, do a check on them first because they can get very dirty with dust from the brake pads.clean them first.let me know how it goes . we get to the next step.

Last edited by csmn10; 04-01-2011 at 01:04 PM.
Reply With Quote
  #4  
Old 04-15-2012, 07:09 PM
Junior Member
 
Join Date: Apr 2012
Location: South Korea
Posts: 3
None None None
Default

I too am having the same issues with my 2000 S500, but a little different. This has been happening for the past week. In the morning (so far only in the morning) I attempt to start the car and nothing happens. The instrument cluster lights up with ABS, ESP and BAS warnings and the center console lights up and goes out. after 5 or more times the center console stays lit and engine will start, but I can't shift out of park. After 5 or more times of starting the engine, I am able to shift out of park, and the car runs great the rest of the day until the next morning. Also on another note that may or may not be related, the dashboard clock has been running slow for the past 6 months. Any help will be appreciated.

Last edited by Steve Tarvin; 04-15-2012 at 07:15 PM.
Reply With Quote
  #5  
Old 04-16-2012, 05:01 AM
Junior Member
 
Join Date: Oct 2010
Posts: 3
Default esp, bas, abs to steve tarvin

does the car struggle to start ?.after the car starts is the message going off.?
Reply With Quote
  #6  
Old 04-16-2012, 11:32 PM
Junior Member
 
Join Date: Apr 2012
Location: South Korea
Posts: 3
None None None
Default Abs/esp/bas

Once the car is started and shifts out of park it runs like nothing happened. I did take the car to the local MB dealer and had them change the brake switch. I will see what happens tomorrow morning. Thanks.
Reply With Quote
  #7  
Old 04-17-2012, 10:22 PM
Junior Member
 
Join Date: Apr 2012
Location: South Korea
Posts: 3
None None None
Default esp, bas, abs light on all time

Well I had the MB dealer change out the brake switch and the same thing happened the next morning. Now I will have to leave it overnight so they can see what I am seeing in the morning.
Reply With Quote
Old 04-17-2012, 10:22 PM
 
 
 
Reply

Tags
2000, abs, bas, benz, e320, esp, light, lights, lihgt, mercedes, problems, relay, s500, visit, workshop


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Advertising
Featured Sponsors
Vendor Directory
Our Sponsors
GetCoolParts.com
Monroe, WA 98272
360.863.0557
All times are GMT -5. The time now is 06:16 PM.

Internet Brands, Inc.



SEO by vBSEO ©2010, Crawlability, Inc.