Mercedes Benz Forums


Go Back   Mercedes Forum - Mercedes Benz Enthusiast Forums > General Mercedes Benz Forums > General Tech
Sign in using an external account
Register Forgot Password?
Search

Welcome to Mercedes Forum!
Welcome to Mercedes Forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to start new topics, reply to conversations, privately message other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, join Mercedes Forum today!

Reply
 
 
 
 
LinkBack Thread Tools Search this Thread
  #1  
Old 07-12-2008, 10:55 AM
 
Join Date: May 2008
Location:
Posts: 15
Default 1989 300E Turn Signals

Stopped working! All bulbs OK! Get steady light only! Any thoughts?
Register today for free or log in if already registered to remove this ad!
Reply With Quote
  #2  
Old 07-13-2008, 09:31 PM
 
Join Date: Jun 2008
Posts: 40
Default RE: 1989 300E Turn Signals

Sounds like either your flasher unit has failed and must be replaced or a bulb is burned out somewhere in the system. You might have to remove all your bulbs to check them one at a time.

Considering the year and body style you might have a cracked tail-light lens that is letting water get into your bulb area. Check this and clean up all the contacts in the rear light assembly even if they do not look bad.

I is also important to use ONLY German blubs which you can get at your Mercedes dealer. I have heard this is not true, but based on what I have seen it is.

Sam
Reply With Quote
  #3  
Old 07-17-2008, 01:56 AM
 
Join Date: May 2008
Location:
Posts: 15
Default RE: 1989 300E Turn Signals

Thanks for your help!

All bulb connections were OK!

I removed the combination relay (turn signal flasher combo unit)located under the hood next to the fuse box. Something was rattling inside the sealed relay! Not a good sign! I ordered a new unit hoping that was the problem! Dealer wanted about $135 plus tax. Autohauz.com charged me about $59, no tax or shipping.
Reply With Quote
  #4  
Old 07-23-2008, 12:16 AM
 
Join Date: May 2008
Location:
Posts: 15
Default RE: 1989 300E Turn Signals

New combination relay did the trick! All is well!

Now waiting for my Euro Headlights to arrive!
Reply With Quote
Old 07-23-2008, 12:16 AM
 
 
 
Reply

Tags
1989, 300e, benz, flasher, lights, location, mercedes, mercedez, removal, remove, signal, signals, turn, unit, working


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Advertising
Featured Sponsors
Vendor Directory
Our Sponsors
GetCoolParts.com
Monroe, WA 98272
360.863.0557
All times are GMT -5. The time now is 06:39 AM.

Internet Brands, Inc.