300SD Rough Idle - Mercedes Forum - Mercedes Benz Enthusiast Forums
Mercedes Benz Forums

Go Back   Mercedes Forum - Mercedes Benz Enthusiast Forums > Mercedes Benz Models > Diesel Discussions

LinkBack Thread Tools Search this Thread
Old 07-18-2006, 08:38 PM
Join Date: Jul 2006
Posts: 38
Default 300SD Rough Idle

Just purchased an 81 300SD Turbo Diesel

The engine idles with extreme vibration. as soon as you touch the pedal to bring it to about 900 RPM it smoothes right out.

It dosent seem to be missing at idle, just really vibrating.

the guy i got it from said it idled smooth before he parked it 2 years ago.... so who knows if thats a lie or not..
motor mounts maybe?

I changed the primaryfuel, main fuel, oil, and air filters today - didnt help at all.

I wound up just raising the idle a bit so the car is more driveable

any thoughts are greatly appreciated!


Reply With Quote
Old 07-19-2006, 05:18 AM
ForcedInduction's Avatar
Super Moderator
Join Date: May 2006
Location: Federal Heights, Colorado
Posts: 5,003
Default RE: 300SD Rough Idle

Try adjusting the rack damper screw on the back of the injection pump. Also, if it has a silver color spring, you should order a new one. The new ones have a stronger gold colored spring that will work much better.

When you are ready to install it, screw it in until it just touches the rack and tighten the jam nut.
A diesel purge can also help. Diesel Purge link
If you have not done a valve adjustment in the last 15,000 miles or within the last year, it's probably due for it. Valve adjust link

Good luck.
Reply With Quote
Old 07-19-2006, 09:21 AM
Join Date: Aug 2005
Posts: 86
Default RE: 300SD Rough Idle

Motor mounts....definitely. You probably have/had and oil leak that soaked the mounts w/ oil. That turns the rubber to mush. It's not a bad job to replace them, I'd do the dampers too. Also check the trans mount.
83 240D 130K
85 300SD 310K
84 300SD 131K
Reply With Quote
Old 07-20-2006, 11:47 AM
Join Date: Jul 2006
Posts: 38
Default RE: 300SD Rough Idle

Motor mount was it! the left oe was shot got it replaced and now it idles smooth!


Reply With Quote
Old 02-12-2007, 10:05 AM
Junior Member
Join Date: Nov 2005
Posts: 16
Default RE: 300SD Rough Idle

I just want to chime in here and say I just tried replacing the motor mounts on my 1984 300D. I did not find it to be so simple a job. There are three bolts to each mount. One bolt goes to the engine and is accessed from under the car. The other two frame bolts appear to be accessed from the top. I was never able to find a way to get to the frame bolts. They are about 2 feet down from the top of the engine and the top of one of the bolts is blocked by the arm that comes off the engine.

I've done tons of work on this car (valves, injectors, veg-oil)and this is only job that I couldn't finish. I ended up taking mine to a mechanic. [&o]
1984 300D Diesel & WVO
Reply With Quote

Similar Threads
Thread Thread Starter Forum Replies Last Post
E300 Running rough, real rough alchan Diesel Discussions 5 04-06-2014 08:24 AM
Loping, rough running, rough idle, missing on one cylinder, almost no power, spark plugs WaBenzer Mercedes C Class 3 08-26-2008 05:41 PM
SLK320 AMG 2003 rough idle Bunnie Mercedes SLK Class 2 12-10-2005 02:52 PM
97 e320 rough idle jon98909090 Mercedes E Class 3 01-20-2005 12:55 AM
rough idle 92 400SE smk51 General Tech 1 07-20-2004 02:25 AM

300, 300sd, adjustment, benz, front, idle, idles, left, mercede, mercedes, motor, mount, mounts, photo, rough, sd, throttle, valve

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -5. The time now is 03:22 AM.